Increased Agent API Latency

Incident Report for Buildkite

Resolved

Database performance has returned to normal.
Posted Apr 16, 2025 - 21:30 UTC

Monitoring

Database performance is returning to normal levels. Response team are monitoring.
Posted Apr 16, 2025 - 20:10 UTC

Update

We're continuing to investigate the database performance issue. Impact is isolated to a subset of customers.
Posted Apr 16, 2025 - 20:03 UTC

Investigating

We're monitoring a performance degradation in one of our pipelines database shards causing some increase in agent API latency
Posted Apr 16, 2025 - 19:00 UTC
This incident affected: Agent API.