Increased latency on artifact uploads

Incident Report for Buildkite

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 17:17 UTC

Monitoring

Artifact upload latency has recovered, and we are monitoring systems
Posted Mar 20, 2025 - 16:59 UTC

Investigating

We're currently investigating increased latency on artifact uploads.
Posted Mar 20, 2025 - 16:39 UTC
This incident affected: Agent API.